Jump to content


Photo
- - - - -

Nissan Wingroad


  • Please log in to reply
5 replies to this topic

#1 preethie

preethie

    Newbie

  • Members
  • Pip
  • 23 posts

Posted 24 October 2011 - 11:38 AM

In my nissan winroad car engine ligt is on.
I showed it to my garaje person (He is expert in Nissan Vehicles) he change the crank sensor.
After change the sensor again light it is on. Then He ask me to get scan report.
I goto A*W and get the scan report. The report is saying EGI unit. they said
clean the EGI unit but my garge person said no point to clean the unit he said
something worng in the car engine computer or the sensor.

If any person knows what is the reson for this please help me.

#2 Kavvz

Kavvz

    Member

  • Members
  • PipPipPip
  • 1,467 posts
  • Gender:Male

Posted 24 October 2011 - 11:59 AM

What error code number do you have listed on the scan report? (Also how much did the agents charge to run the report?) It depends on the code really. Depending on the code you can usually decide whether its serious issue or whether its just a one off situation where you can clear the code and monitor things to see if it reoccurs again, at which point you can address it / replace the offending part.
"Never wrestle with a pig—you get dirty and the pig likes it”- Bernard Shaw.

#3 Ripper

Ripper

    Chief Bottle Opener

  • Members
  • PipPipPip
  • 5,261 posts
  • Gender:Male
  • Location:Colombo - Wattala
  • Interests:weekend mechanics

Posted 24 October 2011 - 12:00 PM

you should've done the scan first! I hope your garage guy had a scanner to get the error code out and it was then he knew it was the crank sensor.
Since the scan was done via A*W now, why dont you get them to sort it out for you instead of going back to your garage chap.

I stopped fighting my inner demons. Now we're on the same side

 


#4 preethie

preethie

    Newbie

  • Members
  • Pip
  • 23 posts

Posted 25 October 2011 - 11:19 AM

Error code is p0400

Thanks for your reply

#5 Kavvz

Kavvz

    Member

  • Members
  • PipPipPip
  • 1,467 posts
  • Gender:Male

Posted 26 October 2011 - 09:45 AM

Error code is p0400

Thanks for your reply


Doesn't seem too bad, as in it doesn't seem like its something that would wreck your engine by driving further. (See here for details on the error code)

I'd reset the check engine light and monitor it to see if it springs up again.

If it does re-occur, I'd go to the local Nissan dealer or a garage with diagnostic tools. Reading through the error code write-up, by using a diagnostic tool you'd be able to figure out what's wrong pretty rapidly which I'd prefer over the trial and error method you'd have to employ at a smaller place that doesn't have it. However if, as you say, your chap is an expert; I guess you could tell him what you suspect is wrong or hand him a printout of the error code data off the web and let him loose...

If you DO go to the dealer get them to give you a written estimate before doing any work, also make sure you talk to the service manager or the foreman in charge so you understand what they plan on doing. Sometimes dealerships (and I speak of dealerships in general) tend to go bonkers and try to replace every darn thing that could be triggering the check engine light without taking the time to diagnose things properly.

Edited by Kavvz, 26 October 2011 - 10:32 AM.

"Never wrestle with a pig—you get dirty and the pig likes it”- Bernard Shaw.

#6 preethie

preethie

    Newbie

  • Members
  • Pip
  • 23 posts

Posted 26 October 2011 - 05:54 PM

Thank you very much for your advice.. Kawz