• 0
asanka_rg

miss fire in cold start

Question

Hi all,

I have experienced considerable missfiring in cold start of my car swift 2003. I have done engine tune up about 3000km back. Now I can feel after starting the car after day or two car is having a hesitation. In D or R the missing is heavy. In p or N that is not much. Driving bit fix the issue. I haven't done a fuel filter cleaning or anything. Please give me some direction to fix the issue in proper way. Where should I start?

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0
56 minutes ago, asanka_rg said:

Hi all,

I have experienced considerable missfiring in cold start of my car swift 2003. I have done engine tune up about 3000km back. Now I can feel after starting the car after day or two car is having a hesitation. In D or R the missing is heavy. In p or N that is not much. Driving bit fix the issue. I haven't done a fuel filter cleaning or anything. Please give me some direction to fix the issue in proper way. Where should I start?

When was the last time you changed Automatic Transmission Fluid?

Share this post


Link to post
Share on other sites
  • 0

Does the engine rev up above say, 1200 RPM at cold start? If it is "miss firing" I suggest you begin the diagnosis by inspecting the spark plugs for possible differences in color and/or deposits on the tip.

Share this post


Link to post
Share on other sites
  • 0

Start with checking the spark plugs, then check your coil packs. The reason you feel it more prominently on D & R is because of the load. Finally check your injectors, fuel pressure and petrol pump. 

1 person likes this

Share this post


Link to post
Share on other sites
  • 0
On ‎5‎/‎15‎/‎2017 at 8:47 AM, Rumesh88 said:

Does the engine rev up above say, 1200 RPM at cold start? If it is "miss firing" I suggest you begin the diagnosis by inspecting the spark plugs for possible differences in color and/or deposits on the tip.

yes rpm is going like 1200 or 1300 and slowly getting around 700. Now the symptom is having in each start up even closer. Is it time to do a tune up ? Meanwhile I will see the spark plugs and injectors also. Fuel filter and pump too.

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, asanka_rg said:

yes rpm is going like 1200 or 1300 and slowly getting around 700. Now the symptom is having in each start up even closer. Is it time to do a tune up ? Meanwhile I will see the spark plugs and injectors also. Fuel filter and pump too.

Was your EGR valve inspected and cleaned during the last tune up? If not I would do that first. Just blindly doing a tune up/clean up will not help in your case (because according to you the car runs normal once warmed up). When the plugs are removed for inspection make sure you identify the cylinder numbers and if two plugs,say 1 and 4 or 2 and 3 shows more deposits than the other two it could be a  sign of a bad coil pack shared by the respective plugs.

Share this post


Link to post
Share on other sites
  • 0

I got the issue fixed which was a leaky coil pack. there was a small hole in the coil tube. I found a used similar tube and fixed. problem goes away. thanks all for comments.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now